Android L: notifiche Heads-Up per tutti su Android 4.0 o superiore grazie ad Xposed

android-l-heads-up

Android L, presentato da poco al Google I/O 2014, ha introdotto un nuovissimo sistema di gestione delle notifiche di cui fa parte anche la funzione chiamata “Heads-Up notifications”, cioè letteralmente “notifiche a testa alta”. Per avere questo stesso sistema di visualizzazione delle notifiche qualche giorno fa vi abbiamo parlato di una applicazione disponibile per Android 4.3 Jelly Bean o 4.4 KitKat.

Adesso, grazie al lavoro svolto da MohammadAG (sviluppatore su xda), è disponibile un modulo per Xposed Framework che permette di attivare il sistema di visualizzazione delle notifiche come su Android L. Ovviamente questa operazione è da raccomandare a chi sa quel che sta facendo in quanto, per usare Xposed, è necessario disporre sul proprio terminale dei permessi di super utente ed avere Android alla versione 4.0 Ice Cream Sandwich o superiore.

UiKXVC9l

Trovate la discussione con la descrizione del modulo su xda a questo indirizzo, mentre per scaricare l’APK di installazione del modulo direttamente sul vostro dispositivo potete cliccare sul seguente collegamento:

Heads-Up Notification | Download

Via

Commenti

Ti invitiamo ad usare toni consoni e di rimanere in tema all'argomento trattato, in caso contrario, il sistema automatico potrebbe oscurare il tuo messaggio e potrebbero trascorrere fino a 48h per la verifica ed un'eventuale autorizzazione.
TuttoAndroid si riserva comunque il diritto di allontanare le persone non adatte a tenere un comportamento corretto e rispettoso verso gli altri.

  • Hermann

    Errore di AnalisiHer

  • Bobba Marchese

    ma quali sono le differenze da quello integrato in gravity?

    • Ennio Arno

      Perchè gravity box ti permette di avere questo tipo di notifiche ?

      • Bobba Marchese

        si, se vai nelle impostazioni della barra d stato

        • Ennio Arno

          Ho appena girato tutte le impostazioni ma relative alle notifiche ho trovato solo “blocca notifiche in corso” e non credo centri niente,a te che voce esce?
          Ho la versione 3.2.0,mi sembra sia l’ultima stabile.

          • amir

            solo su kitkat con gravitybox le puoi avere

  • Fabio

    Ciao! Ho provato a installarlo ed è molto bello! (Nexus 5), l’unico difetto è che quando scrivo mi appare la notifica per la scelta “del metodo di immissione” e non va via fino a quando non “tiro giù” la tastiera.. Ho provato a cercare quale tipo di notifica era per aggiungerla alla blacklist del modulo, ma non la trovo..potreste aiutarmi? :) graziee

    • Fabio

      Ho risolto togliendo la impostazione:) scusate per il commento inutile… comunque funzionante su nexus 5 con CM11

      • Crack

        la CM 11 l’ha già integrato nella ROM

  • fedeangryfe

    Su G2 manda in palla il system

    • Marco

      vero…provato anche su g2 con rom cloudyg3 e va in crash il system

  • Pippuss

    Confermo su jb (4.2.1) non va’…

  • Daniele Corrado

    scusate l’ignoranza ma non riesco a farlo funzionare xD (nexus 4 4.4.4)

  • Nicolò Crick Burattin

    Funziona benissimo:) (Nexus 5 – 4.4.4)

  • Ennio Arno

    Ma il modulo è sempre lo stesso ed hanno ampliato il supporto alle versioni precedenti o è un’altro? nella discussione di XDA nn ho letto tutte le pagine ma danno la compatibilità da KitKat. Qualcuno con Jelly Bean 4.1.2 l’ha provato ?

  • Pietro Furchi

    Sul mio dispositivo ( JB 4.2.1) non é supportato

Top